Bad news everyone! WhatsApp had announced in February how it would stop supporting older smartphones by the end of the year, which means, all older versions of Android, iOS, Windows Phones, Blackberry and Symbian are going to be affected by the decision.

And now, since the end of the year is right around the corner, WhatsApp’s support for older smartphone operating systems is also going to halt soon. According to the makers, this major decision was taken because the company aims to bring about improvements and introduce a lot more features in the app, which can only be supported by newer operating systems.

So here is a list of phones that will be affected by the decision:

iPhone 3GS/iOS 6

WhatsApp services for the iOS 6, which was released by Apple in the year 2012, will come to an end soon.  

BlackBerry OS and BlackBerry 10

WhatsApp will not support most BlackBerry devices that include Blackberry Classic, Blackberry Z10 and Blackberry Passport by the end of June, 2017.

Android 2.1, Android 2.2

Services for the earliest versions of Android, known as Froyo, will halt soon.

Nokia S40, Symbian S60

This also includes older high-end phones such as the 41 MP Nokia PureView 808.

Windows Phone 7

This includes Lumia 510, 710 and 810 smartphones.

WhatsApp is one of the most popular messaging services in the world and has made a whole lot of changes this year which include introduction of video calls and GIF support. So hurry-up everyone! Upgrade your smartphones before the end of December to continue using their services.